Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | See parent post | Go Back
View Post [edit]

Poster: Administrator, Curator, or StaffJonathan Aizen Date: May 16, 2003 9:05am
Forum: etree Subject: Re: Why does my FTP not connect all the way

guys - please help us out here by giving more information. what server? what ftp client? also, scroll down in the forum and see what other users have written about this. hopefully we can get it resolved.

most users who experience trouble are using smartftp.

Reply to this post
Reply [edit]

Poster: MaxPower7707 Date: May 16, 2003 10:47am
Forum: etree Subject: Re: Why does my FTP not connect all the way

it's been happening to me with every server i try. i am using smart ftp. thanks

Reply to this post
Reply [edit]

Poster: Chrispy Date: May 16, 2003 11:14am
Forum: etree Subject: Re: Why does my FTP not connect all the way

I have been having the same problem. Everything was fine until about a week or so, but now the direcotry nver refreshes. It's worst on etree07. I was able to get on last night. I do use Smartftp, ver. 1.0.971. I am able to access other ftp servers fine (non-archive). The norcal server is one example.

Here's a copy of the logs from a transaction.

Resolving host name etree07.archive.org...
Connecting to (etree07.archive.org).
Connected to (etree07.archive.org) -> IP: 209.237.233.247 PORT: 21.
Socket connected waiting for login sequence.
220---------- Welcome to Pure-FTPd 1.0.14 ----------
220-You are user number 62 of 500 allowed.
220-Local time is now 18:08 and the load is 70.67. Server port: 21.
220-Only anonymous FTP is allowed here
220 You will be disconnected after 15 minutes of inactivity.
USER anonymous
230 Anonymous user logged in
SYST
215 UNIX Type: L8
REST 100
350 Restarting at 100. But we're in ASCII mode
REST 0
350 Restarting at 0
PWD
257 "/" is your current location
Cached directory reloaded.
Cached directory reloaded.
CWD /0/audio
Connection closed. Server timeout.
Command aborted. Server timeout.
250 OK. Current directory is /0/audio

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or Staffbleblanc Date: May 16, 2003 11:41am
Forum: etree Subject: SmartFTP issues...

. I do use Smartftp, ver. 1.0.971

The next step to troubleshoot/fix it is to try another client to see if that helps - and PLEASE report back on the results. If we can find a solid answer to this we'll document it for other users.

Almost everyone who reports a problem is using SmartFTP.

FWIW, I just tried to go through the above motions with SmartFTP on etree07, and it took roughly 60 seconds before the server responded to my LIST -aL request. As soon as it did, the listing came right up.

-Brad

This post was modified by bleblanc57 on 2003-05-16 18:41:47

Reply to this post
Reply [edit]

Poster: aquanee Date: May 17, 2003 3:49am
Forum: etree Subject: Re: SmartFTP issues...

I was having the same problem ... I just set my server timeout settings on my FTP Client (SmartFTP) to 500 seconds and waited it out.. eventually the audio folder opened and now I'm downloading.

Reply to this post
Reply [edit]

Poster: bisq Date: May 17, 2003 6:58am
Forum: etree Subject: Re: SmartFTP issues...

I'm using FTP voyager...sometimes it lets me in eventually sometimes it just times out. I agree that it is the worst on etree07. Here is my login data, as you can see it froze as I selected the audio folder (that was about 3-4 minutes ago)

STATUS:> Connecting to "etree07.archive.org" on port 21.
220---------- Welcome to Pure-FTPd 1.0.14 ----------
220-You are user number 52 of 500 allowed.
220-Local time is now 23:37 and the load is 30.46. Server port: 21.
220-Only anonymous FTP is allowed here
220 You will be disconnected after 15 minutes of inactivity.
STATUS:> Connected. Logging into the server
COMMAND:> USER anonymous
230 Anonymous user logged in
STATUS:> Login successful
COMMAND:> REST 100
350 Restarting at 100. But we're in ASCII mode
COMMAND:> REST 0
350 Restarting at 0
STATUS:> Server supports resume
COMMAND:> PWD
257 "/" is your current location
COMMAND:> CWD /
250 OK. Current directory is /
COMMAND:> TYPE A
200 TYPE is now ASCII
COMMAND:> PORT 68,96,52,232,8,202
200 PORT command successful
COMMAND:> LIST
150 Connecting to port 2250
226-Options: -l
226 3 matches total
COMMAND:> CWD /0
ERROR:> Socket error: WSAETIMEDOUT - Connection timed out. Try using PASV mode (View | Options | Connection) if you receive this error during a LIST command. (10060)
STATUS:> Error sending command "CWD /0". Reconnecting (send attempt 2)...
STATUS:> Connecting to "etree07.archive.org" on port 21.
220---------- Welcome to Pure-FTPd 1.0.14 ----------
220-You are user number 57 of 500 allowed.
220-Local time is now 13:54 and the load is 117.43. Server port: 21.
220-Only anonymous FTP is allowed here
220 You will be disconnected after 15 minutes of inactivity.
STATUS:> Connected. Logging into the server
COMMAND:> USER anonymous
230 Anonymous user logged in
STATUS:> Login successful
COMMAND:> REST 100
350 Restarting at 100. But we're in ASCII mode
COMMAND:> REST 0
350 Restarting at 0
STATUS:> Server supports resume
COMMAND:> CWD /
250 OK. Current directory is /
COMMAND:> TYPE A
200 TYPE is now ASCII
STATUS:> Successful reconnect. Attempting to resend failed command.
COMMAND:> CWD /0
250 OK. Current directory is /0
COMMAND:> PORT 68,96,52,232,10,119
200 PORT command successful
COMMAND:> LIST
150 Connecting to port 2679
226-Options: -l
226 1 matches total
STATUS:> Resolving links
COMMAND:> CWD /0/audio
250 OK. Current directory is /0/audio
STATUS:> Resolved 1 link into 1 folder and 0 files
COMMAND:> PORT 68,96,52,232,10,120
200 PORT command successful
COMMAND:> LIST
150 Connecting to port 2680

Reply to this post
Reply [edit]

Poster: TBS - STL Date: May 16, 2003 12:25pm
Forum: etree Subject: Re: SmartFTP issues...

FWIW, i use crystal ftp and experience the same problems once i get to the audio folder. it times me out after like five minutes. i also can't access the shns via the web or the IAFM either. is it just taking forever to connect?

Reply to this post
Reply [edit]

Poster: gsisak Date: May 16, 2003 2:17pm
Forum: etree Subject: Re: SmartFTP issues...

same problem here. using smartftp. logging in anonymously. have no problem when i log into etree07.archive.org/ but when i browse to the 0 folder and then the audio shortcut it just hangs and times me out. the folders with the shows never show up. also tried etree08. i've had it take a while before then they show up but now they're not. my guess is server is just too busy.

Reply to this post
Reply [edit]

Poster: /pushkar Date: May 17, 2003 2:24am
Forum: etree Subject: same problem in cuteftp - etree07

same problem here as well. i am using cuteftp. this only seems to happen on etree07 though.
i can't get into the audio folder. it just stops after CWD audio.


**EDIT = going to try some of the things mentioned in some of the posts below us:)**



STATUS:> Connecting to etree07.archive.org (ip = 209.237.233.247)
STATUS:> Socket connected. Waiting for welcome message...
220---------- Welcome to Pure-FTPd 1.0.14 ----------
220-You are user number 60 of 500 allowed.
220-Local time is now 09:16 and the load is 72.85. Server port: 21.
220-Only anonymous FTP is allowed here
220 You will be disconnected after 15 minutes of inactivity.
STATUS:> Connected. Authenticating...
COMMAND:> USER anonymous
230 Anonymous user logged in
STATUS:> Login successful
COMMAND:> TYPE I
200 TYPE is now 8-bit binary
COMMAND:> REST 100
350 Restarting at 100
STATUS:> This site can resume broken downloads
COMMAND:> REST 0
350 Restarting at 0
COMMAND:> pwd
257 "/" is your current location
COMMAND:> TYPE A
200 TYPE is now ASCII
STATUS:> Retrieving directory listing...
COMMAND:> PORT 192,168,1,100,6,52
200 PORT command successful
COMMAND:> LIST
150 Connecting to port 1179
STATUS:> Received 200 bytes Ok.
STATUS:> Time: 0:00:01, Efficiency: 0.20 KBytes/s (200 bytes/s)
226-Options: -l
226 3 matches total
STATUS:> Done.
COMMAND:> CWD 0
250 OK. Current directory is /0
COMMAND:> pwd
257 "/0" is your current location
COMMAND:> TYPE A
200 TYPE is now ASCII
STATUS:> Retrieving directory listing...
COMMAND:> PORT 192,168,1,100,6,53
200 PORT command successful
COMMAND:> LIST
150 Connecting to port 1218
STATUS:> Received 75 bytes Ok.
STATUS:> Time: 0:00:01, Efficiency: 0.07 KBytes/s (75 bytes/s)
226-Options: -l
226 1 matches total
STATUS:> Done.
COMMAND:> CWD audio


This post was modified by /pushkar on 2003-05-17 09:19:33

This post was modified by /pushkar on 2003-05-17 09:24:52

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or Staffbleblanc Date: May 17, 2003 10:36pm
Forum: etree Subject: So, It isn't just SmartFTP.

I think it's safe to say that downloading that directory list in general is just plain slow no matter what you use for software.

As far as I can tell, it's mainly due to high server load. If you try to login early in the morning, the problem isn't as prevalent, but when more and more people hop on and begin transferring, that initial LIST command just slows down to a snails pace.

Jon? Any ideas?

-Brad

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or StaffJonathan Aizen Date: May 17, 2003 10:50pm
Forum: etree Subject: Re: So, It isn't just SmartFTP.

I talked with Joerg last night and he has some ideas about striping on RAID that might help out. The other option is to forego RAID entirely. These things might help out performance, and we'll try them to see what effect it has.